Проект

Общее

Профиль

Универсальные процедуры и функции (метаданные)

Возвращает полное имя объекта метаданных по переданному значению ссылки

// Возвращает полное имя объекта метаданных по переданному значению ссылки
// Например,
//  "Справочник.Номенклатура";
//  "Документ.ПриходнаяНакладная" 
//
// Параметры:
//  Ссылка - ЛюбаяСсылка - значение ссылки, для которого необходимо получить имя таблицы ИБ
// 
// Возвращаемое значение:
//  Строка - полное имя объекта метаданных для указанного значения ссылки
//
Функция ИмяТаблицыПоСсылке(Ссылка) Экспорт

    Возврат Метаданные.НайтиПоТипу(ТипЗнч(Ссылка)).ПолноеИмя();

КонецФункции

Получение реквизитов объектов (справочников и документов)

Получения реквизитов документа:

Для Каждого Реквизит Из Документ.Метаданные().Реквизиты Цикл
        НоваяСтрока = РеквизитыДокумента.Добавить();
        НоваяСтрока.Реквизит = Реквизит.Имя;
        НоваяСтрока.Значение = Документ[Реквизит.Имя];
КонецЦикла;

РеквизитыДокумента - таблица значений с двумя полями "Реквизит" и "Значение".

Получение табличных частей документа и их реквизитов:

Для Каждого ТабличнаяЧасть Из Документ.Метаданные().ТабличныеЧасти Цикл
        Сообщить(ТабличнаяЧасть);
        Для Каждого РеквизитТЧ Из ТабличнаяЧасть.Реквизиты Цикл
            Сообщить("  -  " + РеквизитТЧ);
        КонецЦикла
КонецЦикла;